fbpx

linear advance

  • This topic is empty.
Viewing 15 posts - 16 through 30 (of 92 total)
  • Author
    Posts
  • #1458
    phongshader
    Participant

    I upped the baud rate to 250000 and I have comms again. :?

    #1459
    dan
    Participant

    Still having issues with the Touch probe? Its not hitting anything during its self test? In fact does it self test OK when powering up? Can you please run the following 2 commands to verify its function :

    Start by turning the printer off , making sure the bed is well clear of probe then turning printer back on.

    Now provide output of M119

    And M280 P0 S600 Does probe deploy? (note in repetier this command is M340)

    M280 P0 S1500 Does probe retract?

    #1460
    phongshader
    Participant

    It does self test.

    Code:

    Send: M119
    Recv: Reporting endstop status
    Recv: x_min: open
    Recv: y_min: open
    Recv: z_min: TRIGGERED
    Recv: z_max: TRIGGERED
    Recv: filament: open
    Recv: ok


    M280 P0 S600 deploys

    M280 P0 S1500 retracts

    When I home the zaxis now the the pin drops, the table rises but does not stop when the pin is pushed in(the sensor never lights) and continues to drive into the printhead until I cut power.

    I played around with the zprobe offset, now it doesn’t crash the print head, the bed stops .4mm below the head, but it still doesn’t zero out and the sensor is blinking in error.

    #1461
    dan
    Participant

    This appears to be a result of disabling the filament out feature. Can you please either re enable it and address any issues with filament out in doing so

    OR disable the Z Max pin by commenting #define USE_ZMAX_PLUG

    Basically because youve disabled Filament out, the firmware is still looking at the Z Max pin though as if it were a normal endstop. This is screwing with your homing as the printer thinks it is already homed to Z max and Z Min ie the printer thinks its too close to the bed upon initialisation and throwing an error.

    #1462
    nevbull
    Participant

    So I managed to get some testing done last night.

    I tried the linear advance diagnostic print using a number of different range settings – from 50 up to 250. All looked bad.

    Went back to Simplify3D – played with the retraction / coast / speed settings – up to 7mm retraction – all still stringing. Have checked steps/mm – bang on with that – all vRefs are ok – motors not running hot.

    Not sure what to check next.

    #1463
    dan
    Participant

    Please run a test pattern and copy and paste the entire repetier host log output from that print (be sure to clear the log before you start). Make sure you enable all log options.

    By the way, why are you using simplify3d for a test pattern? The test pattern gcode is generated with an online tool meaning you bypass simplify3d all together.

    Please either print the gcode directly from SDCard or from Repetier host (if you must use a pc/Mac)

    #1464
    dan
    Participant

    Oh and by the way, are you using repetier or Marlin? Marlin 2.0 function range is maybe 0.0 to 2.5 . Way way lower than what you’re using.

    #1465
    phongshader
    Participant

    dan wrote:


    Basically because youve disabled Filament out, the firmware is still looking at the Z Max pin though as if it were a normal endstop. This is screwing with your homing as the printer thinks it is already homed to Z max and Z Min ie the printer thinks its too close to the bed upon initialisation and throwing an error.


    I think this is in reference to Nev’s post but is it relevant to my issue as well? I have not disabled filament out.

    #1466
    nevbull
    Participant

    dan wrote:


    Please run a test pattern and copy and paste the entire repetier host log output from that print (be sure to clear the log before you start). Make sure you enable all log options.

    By the way, why are you using simplify3d for a test pattern? The test pattern gcode is generated with an online tool meaning you bypass simplify3d all together.

    Please either print the gcode directly from SDCard or from Repetier host (if you must use a pc/Mac)

    I was running the test pattern from the G-Code Library tab of the Machine Control Panel in Simplify3D – and then returned to test printing with a stringing test model from Thingiverse https://www.thingiverse.com/thing:2450004” class=”bbcode_url”>https://www.thingiverse.com/thing:2450004

    Higher numbers were tested as it was mentioned that those worked better for Bowden systems in an earlier post – but I guess for Repetier FW – will retest on wednesday when I’m back in the office

    Thanks again!

    Nev.

    #1467
    phongshader
    Participant

    dan wrote:


    That filament out issue is likely that I need to invert the logic of the filament put sensor.


    On my printer the filament sensor is set up to be open when there is filament and triggered when out. The Marlin firmware is set up:

    Code:

    #define FILAMENT_RUNOUT_SENSOR
    #if ENABLED(FILAMENT_RUNOUT_SENSOR)
    #define NUM_RUNOUT_SENSORS 1 // Number of sensors, up to one per extruder. Define a FIL_RUNOUT#_PIN for each.
    #define FIL_RUNOUT_INVERTING true // Set to true to invert the logic of the sensor.
    #define FIL_RUNOUT_PULLUP // Use internal pullup for filament runout pins.


    Is this the correct logic for this setup?

    #define FIL_RUNOUT_INVERTING false:

    Send: M119

    Recv: Reporting endstop status

    Recv: x_min: open

    Recv: y_min: open

    Recv: z_min: TRIGGERED

    Recv: z_max: TRIGGERED

    Recv: filament: TRIGGERED

    Recv: ok

    OR

    #define FIL_RUNOUT_INVERTING true:

    Send: M119

    Recv: Reporting endstop status

    Recv: x_min: open

    Recv: y_min: open

    Recv: z_min: TRIGGERED

    Recv: z_max: TRIGGERED

    Recv: filament: open

    Recv: ok

    ?

    I’ve been getting this error as well after homing Z:

    Your printer’s firmware reported an error. Due to that OctoPrint will disconnect. Reported error: !! STOP called because of BLTouch error – restart with M999

    #1468
    dan
    Participant

    Not in front of my computer, but there’s another line for z min endstop inverting and another for z max endstop inverting. Check those lines too and reverse whatever logic is there. Don’t for M502 and M500 after updating firmware. Also, run M119 a number of times. Does the endstop states change randomly? If so set the endstop pull-up in the firmware to true.

    Basically , when the printer first turns on and finishes the probe check, all endstop states should read OPEN or untriggered.

    #1469
    phongshader
    Participant

    I did some editing

    Code:

    // Mechanical endstop with COM to ground and NC to Signal uses “false” here (most common setup).
    #define X_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Y_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Z_MIN_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define X_MAX_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define Y_MAX_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define Z_MAX_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Z_MIN_PROBE_ENDSTOP_INVERTING false // Set to true to invert the logic of the probe.


    gives this result after M502, M500 commands:

    Send: M119

    Recv: Reporting endstop status

    Recv: x_min: open

    Recv: y_min: open

    Recv: z_min: TRIGGERED

    Recv: z_max: open

    Recv: filament: open

    Recv: ok

    changing the logic from false to true

    Code:

    #define Z_MIN_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.

    does not

    change the state here Recv: z_min: TRIGGERED, but the good news is homing the z axis appears to function now :D

    #1470
    phongshader
    Participant

    The correct settings for my endstops/z probe:

    Code:

    // Mechanical endstop with COM to ground and NC to Signal uses “false” here (most common setup).
    #define X_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Y_MIN_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Z_MIN_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define X_MAX_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define Y_MAX_ENDSTOP_INVERTING false // Set to true to invert the logic of the endstop.
    #define Z_MAX_ENDSTOP_INVERTING true // Set to true to invert the logic of the endstop.
    #define Z_MIN_PROBE_ENDSTOP_INVERTING false // Set to true to invert the logic of the probe.


    and for the runout sensor:

    Code:

    #define FIL_RUNOUT_INVERTING false // Set to true to invert the logic of the sensor.

    #1471
    dan
    Participant

    M119 can’t really be used for detecting if a probe will trigger as it sends a pulse rather than a constant on or off state. Despite this, Untriggered the probe should read as such with M119. To test if the probe is functioning as intended, just home your printer and hit the probe with your finger. If the bed movement reverses when this occurs, your probe is functioning as intended.

    #1472
    phongshader
    Participant

    I will test it after work today. Ultimately the probe is working, I’m able to home and complete a 6×6 bilinear bed leveling. Now to finish calibrating linear advance!

Viewing 15 posts - 16 through 30 (of 92 total)
  • You must be logged in to reply to this topic.
Facebook Instagram YouTube