fbpx

Layer Shifts / Multi Material 50% Under Extrusion

Forums The Beast V1, V2 and Elevator 3D Printer Support Layer Shifts / Multi Material 50% Under Extrusion

  • This topic is empty.
Viewing 15 posts - 46 through 60 (of 74 total)
  • Author
    Posts
  • #1379
    dan
    Participant

    The penny just dropped :

    According to robot gear, the V2 of this driver is more like a 4988 with respect to pins,

    “This revised version of the DRV8825 breakout board has been improved to have an interface nearly identical to the A4988 board and pin compatible.”

    I can only assume this is why your microstepping pans out differently to ours. According to the Rumba Wiki, having a jumper on the 3rd pin pair should result in 16x microstepping, making the steps per mm value for the Titan extruder 417.5. A4988s don’t have a specification for one jumper on the 3rd pin pair, so it appears the V2 8825 defaults to 32x in this case. If you feel like changing it back (which isn’t really necessary) try using the A4988s definition for jumper placement to result in 16x which is a jumper across all 3 pin pairs.

    https://reprap.org/wiki/RUMBA#Microstepping

    Will running your extruder at 32x make much difference? well… no. The added resolution will give you no measurable benefit from a print perspective, but you may loose some motor torque and potentially generate a bit more heat in the process.

    #1380
    mr.s
    Member

    I jumpered all 3 pin pairs and reverted back to 417.5 steps/mm for the extruder. I now extrude 25 mm, so 1/4 of what it’s supposed to be. It seems like it’s acting as a 64 steps/mm driver now (!)

    So for the extruder I have:

    Jumpers Steps/mm Movement

    All 3 417.5 25mm

    3rd 417.5 50mm

    Furthermore, the z axis, which originally had all three jumpers and was correctly moving 100mm at 3200 steps/mm before, when using just the jumper on the third pair of pins now moves exactly twice as much, which points to a 16 microsteps/mm behavior. If only the third pair jumpered defaulted to 32 microsteps I would expect there to be no change, unless the 3200 steps/mm is wrong.

    So for the z axis I have

    Jumpers Steps/mm Movement

    All 3 3200 100mm

    3rd 3200 200mm

    If 3200 is the supposed value, I don’t see any consistency in the behavior of this board with these drivers (all drivers are the same V2 model).

    I didn’t try all 3 jumpers for X and Y drivers, but with just the third pair of pins jumpered and 80 steps/mm the movement is the correct 100mm.

    Do you make any sense out of this? If not, could you link to a valid replacement for the drivers?

    As a side note, in doing my tests, I noticed that both extruders move when sending the G1 E100 command. Is this right?

    Is there some command that enables/disables T0 and T1 that I should send in order to test each extruder individually?

    #1381
    dan
    Participant

    This from the MM profile start script section, it may be easier to copy and paste this to a new file and call it setup.gcode, then run it before any other commands :

    G28 ; home all axes

    ; Add Extruder 0 no mixing

    M163 S0 P1

    M163 S1 P0

    M164 S0

    ; Add Extruder 1 no mixing

    M163 S0 P0

    M163 S1 P1

    M164 S1

    ;End of file

    You should then be able to select extruders with T0 or T1 and run G1 E100 to extrude 100mm.

    In regards to your microstepping. Im really confused. Perhaps the problem was not running that code first? I doubt it but worth a try.

    In terms of stepper drivers. Ive never seenthis V2 8825 driver before. Usually any purple or black DRV8825 will be a suitable replacement.

    We may be on the wrong track. Maybe this is a gearing thing either with the motor being .9 degree steps or the titan gear. Thing is we havent changed extruder or motor suppliers for a long time, im certain id have seen this before. We need to figure out if this is actually moving in 16x or 32x, not that either would cause double extrusion during printing.

    So heres a test, unplug X and plug it into E0, change e0 steps per mm to 80, preheat hotend, run the above gcode, select T0 and “extrude” 100mm. Does the X motor move 100mm? If so, it is infact in 16x and the motor must have .9 degree step angles. At least that will give us some clarity as to what is actually going on.

    #1382
    dan
    Participant

    If it does, it’d be the strangest faulty behaviour I’ve ever seen.

    Let me mull over the evidence we have. I’ll get back to you a little later.

    FYI You can “home” the printer by just clicking the endstop with your finger.

    Just a thought… filament diameter is set to 1.75 correct?

    Also can you please post a backup of your eeprom (via tools-firmware eeprom configuration) and also a copy of your configuration.h? Also while you’re at it. A copy of your test cube gcode file would also help.

    #1383
    dan
    Participant

    Quote:

    But I changed the steps/mm to 80 on E1, preheated and run G1 E100 command. 50 mm movement with just the third pair jumpered.

    With all 3 pair jumpered, X moves 25 mm.

    OK so this is interesting. Is the jumper underneath the X driver the same as the extruder drivers?

    #1384
    mr.s
    Member

    I emailed you the eeprom file.

    The filament is set to 1.75 in Simplify3D ‘Other’ tab, if that’s where I’m supposed to look.

    Not sure how to save the configuration.h file.

    As far as the g-code, I have gone through and discarded so many versions that I lost track of them. I know that the best quality came out of a configuration where the extruder moved 50mm out of the G1 E100 command, so that probably doesn’t help much.

    #1385
    dan
    Participant

    The configuration.h is part of the firmware. Am i correct in assuming you havent tried flashing the firmware?

    Perhaps worth a try if not. Download from here : https://cultivate3d.com/firmware

    You can follow the process in this video https://youtu.be/QtLlF5emYCU just dont worry about changing any values in the configuration.h file a fresh copy of the firmware will have those changes.

    Once the fresh copy of firmware is loaded, Run M502 then M500 to clear eeprom

    #1386
    mr.s
    Member

    I flashed the firmware, run M502 and M500 commands, preheated hotend and run G1 E100 command.

    50mm came out.

    I’m leaning towards a faulty board at this point, but in order to rule everything out I’d like to try the correct drivers in there first.

    Can you link to a replacement that you know works for sure?

    #1387
    dan
    Participant

    Do you have none of the ones that came with the printer? They should work for sure.

    https://www.amazon.com/HiLetgo-DRV8825-Stepper-RAMPS1-4-StepStick/dp/B01NCE3ZW1/ref=sr_1_5?keywords=DRV8825&qid=1578891834&sr=8-5

    Please save and use this gcode to test :

    ;start of file

    ; Add Extruder 0 no mixing

    M163 S0 P1

    M163 S1 P0

    M164 S0

    ; Add Extruder 1 no mixing

    M163 S0 P0

    M163 S1 P1

    M164 S1

    M104 S180 T0 ;Preheats Hotend

    M109 S180 T0 ; waits for temperature to reach 180

    G1 E100 ;Extrudes 100mm

    ;end of file

    I really doubt this is a faulty board. One last test Can you try downloading the single hotend firmware then do the extrusion test. This should eliminate any bugs in the firmware with manual extrusion on a mixing system.

    Ill email you when I get in at 8:30am Australian Eastern Standard Time (AEST) – can we setup a teamviewer and facetime (so I can see whats going on)?

    #1388
    mr.s
    Member

    I tried the single hotend firmware and now it extrudes the right length. I think we found our culprit.

    It works with the same steps/mm and jumper configuration of the original drivers (417.5, just third pair). Tested all axes as well. All good.

    Z axis has all jumpers in, and set for 3200 steps/mm, so it appears that the jumper configuration is the same for the V2 of my drivers as for the original ones, after all. At least for 1/16 and 1/32 config.

    I can definitely use the single hotend firmware while you troubleshoot the 2 in 1 firmware, since I never even used the second extruder until now.

    The big question is: could this have been the reason for the layer shifts?

    #1389
    phongshader
    Participant

    I’m watching this with great interest as I’m having the same issues with the extruders.

    #1390
    dan
    Participant

    Maybe. But I doubt it. At the very least we know what your extruder is doing.

    I’ll have a play with that firmware over the next few days. I’ve certainly produced perfect MM prints with that firmware without any issues. I have a feeling this is only related to manual extrusion, and as you pointed out doubles the extrusion while printing.

    Those layer shifts were more likely caused by something else though. The answer is usually pretty clear if you can catch this when it occurs. Ie. you can see if the hotend is flopping around or getting caught on z artefact. Sometimes you’ll hear a clunking sound of a motor skipping steps (insufficient power or bad connections) or opposite, see nothing but notice the x or y motor stop short in either direction (indicating driver shutdown (too much heat. Enclosure fan running?)). It’s now time to go back to those test cubes. When you send pictures I really need to see the cubes from side on and oblique angles.

    You don’t have any filament that shoots better than the natural (translucent) stuff you had earlier?

    When we’ve got that right, we’ll scale it up maybe 400% and see how the results play out.

    While it’s printing. From time to time, put your hand on the x and y motors to ensure they’re not getting hot to leave your hand on. If they are adjust stepper power down a fraction.

    #1391
    dan
    Participant

    So just doing some research and definitely this is because repetier firmware needs to know how to “Mix” the materials. That start Gcode I gave you before should have done that for you. First it set the mixing for both tools to 100%, then the hotend was heated, then T0 was selected and then it was told to extrude 100mm. We’re you using that gcode? I’m guessing if you were, you probably had the steps per mm set to 835 instead of 417.5?

    Moral of the story thus far, is ignore manual extrusion for the moment. Set microstepping to 16x and steps per mm back to 417.5

    Although I feel it would be easier to sort this seemingly seperate layer shift issue first with the single v6 firmware and once figured, go back to the MM firmware.

    Dan

    #1392
    dan
    Participant

    Perhaps you could save me the trouble of cannibalizing my test rig (again).

    Try turning off the mixing extruder option in the MM firmware from the configuration.h file change :

    #define MIXING_EXTRUDER 1

    to

    #define MIXING_EXTRUDER 0

    This is remove all of the superfluous mixing code required in the startup gcode script as well as hopefully allowing manual extrude to work as expected without that startup code.

    #1393
    mr.s
    Member

    I’m going to do some test cubes with the single hot end firmware first.

    I don’t know hot to save the code in a file and send it all at once to the printer. Maybe you can guide me for that.

    However, I had sent each command individually before, and the results were still incorrect, with the 2 in 1 firmware.

Viewing 15 posts - 46 through 60 (of 74 total)
  • You must be logged in to reply to this topic.
Facebook Instagram YouTube