fbpx

How to update Firmware AND Bed Homing into nozzle – Probe Error – Not homing correctly, Auto level failing

Forums The Beast V1, V2 and Elevator 3D Printer Support How to update Firmware AND Bed Homing into nozzle – Probe Error – Not homing correctly, Auto level failing

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1172
    dandan
    Participant

    Hi Folks,

    Thought i’d do this quick write up on an issue that’s been effecting a number of customers relating to the unit not homing. It appears as though the current batch of probes requires some slightly different settings in order to have the probe deploy the probe and retract the probe more quickly. Making this change should rectify issues relating to the probe going into error, Auto leveling not completing, and bed homing into the nozzle. Overall this change should improve the reliability of any functions relating to the touch probe.

    (These instructions were written for Windows. MAC OSX systems, everything is mostly the same except step 7, your printer may appear differently to that specified below. It should still show as an Arduino device Mega 2560 (or words to that affect)).

    https://youtu.be/QtLlF5emYCU

    Basic Steps (In a Nutshell) .

    1) Download and install Arduino IDE https://www.arduino.cc/en/Main/Software

    2) Download and install WinRAR https://www.win-rar.com/download.html?&L=0 (used to extract the firmware file)

    3) Download and extract The Firmware for your printer with WinRAR http://cultivate3d.com/firmware (leave folder contents intact – just hit the extract button – default options)

    4)Connect your your printer to computer via USB cable

    5) Open the “repetier.ino” file you extracted in step 3, it should open in Arduino IDE

    6) In Arduino IDE, select Tools > Board > Arduino / Genuino Mega or Mega 2560 (you cant see me select this in the video – the menu goes off the screen).

    7) In Arduino IDE Select Tools > Port > COM* Arduino / Genuino Mega or Mega 2560 (the * will be a number and differs from machine to machine ie COM3)

    8) Click on the configuration.h file from the tabs across the top. If you can’t see it, look for a small downwards arrow icon in the top right of Arduino IDE then select the configuration.h file

    9) Ctrl+F to bring up the find window OR click Edit > Find from the top menu

    10)In the find window search for the following (without quotes) “M340 P0 S500” and click find

    11)Edit the found text and change it to “M340 P0 S600”

    12)Click the Upload icon > (Right facing arrow in top left of Arduino window)

    Now try and home your printer – you should find it now homes correctly and reliably. If not. Let me know.

    Why does this work?

    Its likely if this issue worked for you that the problem causing your homing to fail on occasion was the fact that when the probe was instructed by the electronics to deploy, a small delay of 0.5-2 seconds occurred. This delay caused the probe to drop late and hit the bed as the bed was raising and the probe was dropping causing the probe to enter an error state. Changing this setting to M340 P0 S600 causes the probe to drop more instantly preventing the bed from hitting the probe as it is dropped.

    FYI The original probes released with this unit responded nicely when M340 P0 S500 was issued. The newer probes require this change to cause them to respond more instantly to commands executed by the firmware.

    #1331
    csandwellcsandwell
    Member

    Dan, I uploaded the firmware with the above M340 P0 S600 change and the probe is still not dropping when homing. The probe extends and retracts on power up and had previously extended for homing. Any ideas?

    #1332
    dandan
    Participant

    Open up repetier host , go to the manual control > gcode tab and enter M340 P0 S600 . Does the probe drop? Now type M340 P0 S1500 Does the probe raise? If it raises or lowers, does this occur the moment you press enter? Is there a delay?

    I have a feeling those codes wont work from what youve described meaning you need to check the wires running between the probe and the EXP3 connector on your main board (the 3 wires). A Multimeter on beeper mode will assist greatly here. Phongshader has reported an issue with some of the header pins we supplied to extend wires – said that his were too tin and didnt make good connection. Perhaps you could check and let me know. If need be ill send some fatter ones.

    #1333
    gosh88gosh88
    Member

    I am having a problem with the homing. My X and Y stops are not working correctly. when its trying to home it hit them and then turns the system off. 🙄 😥

    #1334
    gosh88gosh88
    Member

    it keeps hitting the endstops. is ther any way to fix this?

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.
Facebook Instagram YouTube