fbpx

Calibration/Tuning instructions

Forums The Beast V1, V2 and Elevator 3D Printer Support Calibration/Tuning instructions

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #1167
    phongshaderphongshader
    Participant

    Hi Dan, do you have a tuning/calibration guide specific to this printer? I’ve seen references to other guides using different firmware/software to get the job done which is fine if you want to spend time translating from Marlin to Repetier or MatterHacker to Repetier. It would be great if C3D would write something up that is specific to their own printer instead of relying on 3rd party generic instructions. If I missed the instructions somewhere I apologize.

    #1281
    phongshaderphongshader
    Participant

    I’m using these instructions here, https://www.instructables.com/id/Calibrating-your-3D-printer-using-minimal-filament/ at least they’re using Repetier. The values I’m getting for the extruder seem a bit off only because I would think the values in the firmware would be correct because you are dealing with a known quantity, that is you know the stepper micro stepping is set to 16x, the gear for the extruder is a known gear ratio…why, when I request an extrusion of 100mm would I only get 51.43mm? The firmware was set to 417.5 steps per mm, which seems right, I’ve seen you mention that number elsewhere. In order to get a 100 mm extrusion I needed to up the steps per mm to 820.63, also I needed to put in a value of -100 to get the extruder to extrude not retract. Something seems off but I’m probably wrong although having to enter a negative value to get a positive extrusion doesn’t seem right. A good write up in the manual would do wonders here ;)

    #1282
    dandan
    Participant

    Hmmm, if you’re getting the wrong amount of filament out of your extruder, 100% the problem is you’ve not set the microstepping jumpers under the stepper drivers. Please check around page 75 of the CURRENT manual as these settings have changed during the past year.

    You should not need to diverge from the set values much at all. Around 417 is the correct value.

    You are correct. We do use repetier firmware. We also use generic components such as the hotend and extruders.

    I’ll consider adding this detail to the manual despite the fact this has been documented with excellent relevance in countless other places.

    #1283
    phongshaderphongshader
    Participant

    Quote:

    100% the problem is you’ve not set the microstepping jumpers under the stepper drivers.

    I’m pretty sure I did set the jumpers, here is a photo of my settings.
    [attachment=0]drv8825 jumpers.jpg[/attachment]

    #1284
    dandan
    Participant

    They all look correct. Now if you replace those drivers run M502 then M500 to clear the settings and load defaults, your extruder should be set to run at 417.5 steps per mm. Extruding 100mm from the LCD should now extrude the correct amount.

    Let me know how you go.

    #1285
    phongshaderphongshader
    Participant

    That didn’t fix the feed rate. ¯_(ツ)_/¯ I reset to 417.5 and the extrusion was cut in half 100 input 51.36 output
    [attachment=1]Screen Shot 2019-12-29 at 4.32.13 PM.png[/attachment]
    [attachment=1]Screen Shot 2019-12-29 at 4.32.13 PM.png[/attachment]

    #1286
    phongshaderphongshader
    Participant

    Any suggestions on how to proceed? I’m getting over-extrusion with my current settings 820.63 and yet the amount of filament extruded from the titan extruder matches the input. I’ve had to dial back the extrusion multiplier to .75 in s3d to get to a finished print but it’s still too much. Again if I set to

    417.5 steps/mm the extruded filament is cut in half, 100 input 51.36 output.
    [attachment=0]IMG_1065.jpg[/attachment]

    #1287
    dandan
    Participant

    Sorry about the late reply. Bloody posts going to spam filter. It sounds like your hardware settings are working. Here are the software settings which could be effecting over extrusion :

    Nozzle diameter (too big)

    Retraction (is motor skipping -listen for beeps on retracts. If so, slow retraction speed or lower retraction acceleration in EEPROM until beeping stops.

    Extra filament after retract

    Extra filament in tool change

    Extrusion multiplier (in your slicer)

    Line width and height.

    And only because I know you’ll probably do it : Linear Advance. (You’ll need to enable it in firmware first). Post a new thread if you’d like help with that.

    Let me know if any of this helps. If not I’ll help you get to the bottom of it.

    #1288
    phongshaderphongshader
    Participant

    Any guidance on what I should be looking at to fix this? I’ve calibrated all the axes, the steppers per Dan’s instructions, the extruders(although the settings are a bit odd but the extrusion is correct). There was some obvious step skipping on the X axis in the print. I have the extrusion mult. set to .8 with a layer height of .02, .04 nozzle.
    [attachment=1]IMG_1074.jpg[/attachment][attachment=0]IMG_1077.jpg[/attachment]

    #1289
    dandan
    Participant

    Hi Phongshader I’m sure you’re following this.

    https://cultivate3d.com/forums/viewtopic.php?f=3&t=51&e=1

    Those pictures look like they’re way way over extruded causing layer shift from bed moving or part moving usually because the nozzle is catching. This layer shift is different from typical skipped steps as the shift is gradual, rather than big obvious chunky shifts. I have a feeling the key here may be to set the steps per mm back to 417.5 with 16x microstepping 1.0 multiplier and ignore the fact that manual extrusion does strange things with MM firmware.

    By the way, while that was printing, could you hear the nozzle dragging over the print during travel moves?

    #1290
    phongshaderphongshader
    Participant

    I will switch back to 417.5 steps to test and yes I can hear the dragging across the print at times.

    Thanks for your help!

    #1291
    dandan
    Participant

    No probs. Let me know how you go.

    #1292
    phongshaderphongshader
    Participant

    Something funny happened when I reverted to the “correct” steps/mm for the extruder…it was extruding the correct amount, not half. I don’t know what happened but I messed around with those settings for a week and could never get them right and then last night it worked. ¯_(ツ)_/¯

    The print has gotten much better but could still improve.
    [attachment=2]IMG_1078.jpg[/attachment][attachment=1]IMG_1079.jpg[/attachment]
    The supports under the center of the wheel printed but then failed as soon as the wheel started to print on the supports.
    [attachment=0]IMG_1081.jpg[/attachment]

    #1293
    dandan
    Participant

    Still looks a bit over extruded. Please reduce the extrusion Multiplier by 5%. In terms of your supports, small fine supports are a recipient for disaster. Try increasing the support size to give it more footing and print with a brim 0cm from the parts to give the supports a nice pad to help with adhesion to the bed. A few support base layers also wouldn’t hurt. I’m sure there are a few videos on customising supports in simplify3d that would hurt to watch.

    #1294
    phongshaderphongshader
    Participant

    The print quality is getting better, these are printed with a raft and a multiplier of .95. I’ve run into an anomaly…I don’t know if this is a slicer issue or a printer issue. If you look at the attached photos you’ll see that the printer is not laying down circles but circles with a small flat sides on the y axis. These flat sides are not present in the slicer simulation.

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.
Facebook Instagram YouTube