fbpx

Reply To: Layer shift on large print

Forums The Beast V1, V2 and Elevator 3D Printer Support Layer shift on large print Reply To: Layer shift on large print

#1431
dandan
Participant

What are your VREF values for X Y and Z?

Make sure it is taught, and when plucked doesnt flop around. if it vibrates for 5-7 seconds and makes a nice low bass tone, then you’ll be fine. https://www.youtube.com/watch?v=B7A-nBHtSOY

For this sort of issue. Take a methodical approach. There are literally hundreds of secondary causes of layer shift, trunking down it the following few categories

1)Insufficient or over power / per torque requirement (vref values will provide an indication here) If stepper driver is hot to touch, you know you have a problem.

2)Physical obstruction **highly possible with large nozzle.

If its an over power issue, stepper driver heat will give an good indication.

Under power, stepper driver likely cool to touch, however when manually obstructed, motor will skip steps easily – just move X 100mm while creating an obstruction with your hand, does the motor push you out of the way easily? Or does your motor skip steps?

Physical obstruction : Large nozzles need a very tightly calibrated extrusion. A small artifact with a small nozzle is easy for the hotend to iron over. Likewise a large artifact produced by a large nozzle can create a physical obstruction impossible to iron over leading to skipped steps. For this reason, with large nozzles – ooze and over extrusion should be as tightly controlled as possible.

1) Do an extrusion calibration – very very important. Ive written about this a number of times – Check my other posts.

2) Check the nozzle diameter is what you think it is : Manually extrude some filament using your LCD, try to avoid letting it stretch as it extrudes and measure width with calipers? Any where near what you thought it was? Consider turning off Automatic Extrusion width in your slicer and also consider reducing extrusion multiplier until large unwanted artifacts which cause skips disappear.

Lastly and not absolutely required if the above is done properly- Only once you are certain your have verified your nozzle width and calibrated your extruder, consider enabling and using M233 Linear advance : Google Repetier Linear Advance ie https://forum.repetier.com/discussion/6971/lin-advance-setup Youll need to enable in your configuration.h file first, upload to your board, set up a calibration script, run it, analyse the results and add the correct Lin advance value to the start of any print (in the start gcode section of your slicer). Lin advance is a large topic. There’s a lot of conflicting information given different version of Marlin and Repetier. IMO useful values for repetier are between 0-200 ie. M233 Y90 – This is my value with a 700mm tube and .4mm nozzle with V6 hotend. Yours will be different.

Lin advance is a big topic and information can be difficult to decipher given the different implementations. You can certainly use Lin advance Test code Generators https://marlinfw.org/tools/lin_advance/k-factor.html made for any Marlin version if you wish, just bear in mind you may need to use Notepad++ to find/replace instances of “M900 K” to “M233 Y” and also set the starting and ending value much higher IE 0-250.

Perhaps first, try and get and idea of what it does by watching some videos and doing some reading then feel free to ask if you have any specific questions.

Facebook Instagram YouTube