Loading... Please wait...

Troubleshooting / F.A.Q

F.A.Q

Question Answer
Can "The Beast" be used as a single head printer?  Yes.  If you wish to take advantage of a larger print area at the expense of additional print heads, "The Beast" can easily be configured this way.  
   
Can "The Beast" print in 4 colours on the one print? "The Beast" can print with up to 3 colours / materials on the one print with a small change to the firmware and wiring.  Contact us this if you want to achieve this AFTER you have built your printer. One of our staff will provide instructions.  
   
Can you print a part for me? No, please ask in our community forum.  
   
My Printer has missing parts? Possibly, but more likely is you have a newer version of The Beast which does not require the parts.  For an up to date list, download a new, current manual from the link at the top of this page.
   
The price at Paypal is different to the price on the website? Paypal may be using a different currency to the one you are using with our website.  The currency you are using on our website is listed in the top right of any page.  
   
How long does it take to ship? We expect all orders to be shipped within 3 weeks
   
How long will it take to arrive? Depends on where you live.  We use DHL for shipping, standard DHL express freight times apply.  You can check freight times on DHL's website.  The Product is shipping from Sydney Asutralia.
   
Is there a pre-built "The Beast" option? Not at this stage, however if you ask nicely in our forums, one of our members may be glad to do it for a price. 
   
Can I order The Beast in a custom size? Not at this stage, however we are working on a number of new size options as we speak. 
   
What filament does "The Beast" take? Out of the box, The Beast takes any generic 1.75mm filament.  We recommend 1.75mm PLA.  The E3D extruder is more flexible as it supports different types of filament which require higher heat to melt.  
   
Is there a heatbed option? Yes and no. We have come up with a heat bed solution which you can build yourself on our forum. We do not currently have a commercial product, however we are working on it.

Trouble Shooting

Symptom Possible Problem/Cause Solution
Arduino gives me errors when I try to upload or compile Wrong Arduino IDE version Download and install version 1.6.9 from here https://www.arduino.cc/en/Main/OldSoftwareReleases#previous
     
Nothing Coming from Printhead  Nozzle Blocked Clear nozzle with suitable copper wire strand.
  Extruder turning in wrong direction Flip extension wires
  Wires loose check wiring, make sure all extensions are secure and wires secures to electronics board properly.
  Filament may be caught prior to hotend Remove bowden tube from pushfit adapter, push filament through and check it is going all the way into hotend
  Blob of filament prior to heaterblock Filament may have heated in the neck of the heaterblock, usually due to gaps in the construction of the hotend and insufficient cooling of neck of hotend.  Check fans are working
     
Incosistent extrusion Extruder Hobbed Gear Loose Check Hobbed Gear grub screw is tightened onto flat of motor shaft
  Filament condition poor inside Bowden Tube remove all filament from Bowden Tube, trim and replace
  Extrduer current too low Adjust trimpot on stepper driver - clockwise to increase
  Extruder motor too hot / current too high Check for blockages and descrease current on stepper driver.
  Extruder motoor too hot / not enough cooling Check fan ontop of extruder is working
  Extruder slipping Tighten extruder tension springs
  Extruder skipping steps Loosen extruder tension springs
    Increase power to extruders by rotating stepper driver trimpot clockwise 1/4 turn
    Pre-heat hotends, remove filament from line, ensure filament moves easilly through bowden tube with little resistance.  Check condition of filament, are there bends and kinks?  Also check bowden tubes are running in a smooth arc from the extruder to the hotend.  Bends in the bowden tube increase friction.  
    Check you have not confused wires between extruder motors, extruder 1 and 2 should be wired together and 3 and 4. If wired incorrectly, low torque will be evident on each extruder, extruders may spin unexpectedly or jog forward and back
  Too much pressure in nozzle Slow down Print Speed
    Decrease stated nozzle size in software ie if using .5, reduce to .4 or .35
    Increase hotend temperature by 10 degrees
  Hotend not heating Check wiring
     
Hotend not heating Wiring problem Check Heater Cartidge with multimeter.  Is circuit open? Replace cartridge
  Thermister faulty  Check no short in thermister wires prior to thermister.  
  Poor connections Follow and check all connectioned wires down to electronics.
     
Vertical walls skewed on printed parts Bed moving during print Secure bed with wedges to prevent movement - do not clamp bed - it will warp.
     
/ misaligned print layers Belts slipping Tighten belt clamps
  Motors skipping steps - motor too hot Motor should be warm, not hot.  If so, reduce current with trimpots on stepper drivers
  Motors skipping Steps - Catching on printed part Reduce filament flow by 10% and retry print
    If on first few layers, slow down print by 20% and retry
  Too low torque to X and Y Motors Use 16 x microstepping instead of 32x (should be 16x if instructions were followed)
     
Top and bottom surface contains small particles of filament (hashed up) on one printhead but not others Over extrusion Check Hobbed gear is aligned to the center of the filament
  Bed not Flat check bed leveling
  Starting distance from bed to small increase bed offset in slicer software
    Decrease flow
    check for blockages in nozzle
     
Uneven wall surfaces Over / Under extrusion Adjust print settings
  Eccentric Nuts not tight enough Tighten Eccentric Nuts
  Merlin heater block loose  Ensure the Merlin hotend is screwed together tightly
  Motor Skipping Adjust Power to stepper driver
  Extruder Idler tension too low Tighten springs 2 Turns.
  Printing too fast  Reduce Speed Multiplier
     
Printing just stops But X Y still moves One of the heaters has stopped functioning or a thermister is not functioning Check temperature display on LCD (rotate knob counter clockwise) Faulty unit will display "dec".  Test this heater block by heating it independantly.  Does it achieve target temperature in reasonable time?  Does it work at all?
    Wrong thermister monitoring wrong hotend.  Test wiring with multimeter or heat suspect hotend and watch if another hotend increases in temperature.   
     
X, Y Or Z Axis moves in unexpected direction Cables wired backwards Flip cable extension connector for all motors on affect axes


Newsletter